top of page

Supported Technology Platform

There are some Hardware and Software requirements that you need to have in place in order for us to meet our service obligations. We will update this list from time to time as certain technologies age and other technologies are released and tested by us. If an item requiring support does not meet our minimum standards, we will provide support on a 'best-efforts' basis.  

Computers

  • Intel i5 or better

  • Intel i-series 8th Generation or newer

  • Windows 10/11 Professional/Enterprise/Business

  • Dell or HP Business Models

  • 8GB RAM or better

  • Solid State Drive

  • Vendor Supported Warranty

Servers

  • Intel Xeon Processor

  • Windows Server 2016 or later

  • Dell or HP

  • 16GB RAM or better

  • Hardware RAID Array

  • Dell iDRAC, HP iLO or similar

  • Redundant PSU

  • Vendor Supported Warranty

Firewalls

  • Untangle Z4 NGFW or better

  • Meraki MX Series

  • Ubiquiti Unifi USG

Switches

  • Ubiquiti Unifi US Series

  • Aruba Instant On

WiFi Access Points

  • Ubiquiti UAP Series

  • Aruba Instant On

Network Attached Storage

  • Synology SMB and Enterprise Models

Software and Cloud Services

  • Windows 10/11 Professional/Enterprise/Business

  • Microsoft 365

  • Microsoft Azure

  • Microsoft Office 2016 or newer

  • Netko IT Managed Next-Gen Antivirus

  • Adobe Suite (latest supported)

  • FoxIT Reader (latest supported)

  • Microsoft Edge, Google Chrome, Mozilla Firefox (latest supported)

  • All third party LOB applications must have current vendor support

bottom of page